Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2020-05-06 06:31:18

Registered: 2020-04-22
Posts: 4

[solved] Compiler issues

I've downloaded the Compiler environment no issues using the wiki links. Each time I compile using the make all & & make clean commands it compiles and then deletes the compiled files. If I only run make all I can update my clone proxmark3 easy and it shows boot rom and firmware versions correctly but shows unclean suspect. I then used the precompiled files released by iceman and they cleared the unclean but still show suspect.
I've made sure the files are latest available, re-cloned he repository a couple different times to make certain. Is there an alternate development environment that will also compile the needed files?

For clarity, I have tried the latest three versions of the iceman and core precompiled and they do offer the functionality I need at this time. I am using an i5 64 bit processor running win 10. I know my comp is older and the forums have shed light on my other minor issues but this compile is bugging me. I've worked on this a couple weeks now on my days off.

Last edited by Drachimus (2020-05-06 11:56:33)


#2 2020-05-06 08:49:15

Registered: 2019-05-11
Posts: 305

Re: [solved] Compiler issues

Can i get you to post the link for the instructions you followed ?

Each time I compile using the make all & & make clean commands it compiles and then deletes the compiled files

I would expect that as the make all && make clean are backwards.
make clean will delete the compile files etc to get ready for a clean make.
i.e. it should be

make clean && make all

As for the dirty/suspect that could be a git thing.  e.g. If i git clone in windows 10 then compile in proxspace, the proxspace git check will report dirty.  but if I git clone and compile from within proxspace then its OK.


#3 2020-05-06 10:24:18

Registered: 2020-04-22
Posts: 4

Re: [solved] Compiler issues

I will definitely reverse the commands and recompile that way. I used them make all & & sake clean as that's the order they're present in the documentation. I did a copy /paste the first time I ran it.

With the git, I used github for windows to clone the repository I'll have to try git through proxspace.

Thank you very much for the help. I'll report back after I try these suggestions out.


#4 2020-05-06 11:56:06

Registered: 2020-04-22
Posts: 4

Re: [solved] Compiler issues

Just and update;

I used the make clean && make all and all went to plan. for whatever reason I thought the make clean was a validity check of some sort. (shows how long it's been since I've used bash or linux)

used the git clone command from proxspace, recompiled the source and it did clear the unclean from the hw version output but as shown below it still shows suspect. that tag isn't too bog an issue for me as the version looks to be current.

Thank you @mwalker for the help in getting my process straight.
My appologies, I just noticed the request for the link to the instructions. it was a doc in the repository,a pdf version of the getting started page. when i went back to it it was already corrected

Prox/RFID mark3 RFID instrument
bootrom: master/v3.1.0-197-gebf1404-suspect 2020-04-11 16:51:24
os: master/v3.1.0-197-gebf1404-suspect 2020-05-06 10:09:50
fpga_lf.bit built for 2s30vq100 on 2019/11/21 at 09:02:37
fpga_hf.bit built for 2s30vq100 on 2020/03/05 at 19:09:39
SmartCard Slot: not available

uC: AT91SAM7S512 Rev B
Embedded Processor: ARM7TDMI
Nonvolatile Program Memory Size: 512K bytes. Used: 211267 bytes (40%). Free: 313021 bytes (60%).
Second Nonvolatile Program Memory Size: None
Internal SRAM Size: 64K bytes
Architecture Identifier: AT91SAM7Sxx Series
Nonvolatile Program Memory Type: Embedded Flash Memory

Last edited by Drachimus (2020-05-06 15:28:28)


Board footer

Powered by FluxBB