Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2014-03-12 17:28:17

emada
Contributor
Registered: 2014-03-12
Posts: 13

debian and proxmark3

So I got a old proxmark3 from a buddy of mine and im trying to use it in linux but it keeps coming up as HID device. I have black listed the device via a udev rule as it says in the setup guide now I am using the root user so I should not have to worry about group membership all i need to do is remove modem manager. Is that correct? Thank you for your time.

Offline

#2 2014-03-12 23:50:22

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

here is some info from syslog:
Mar 12 20:46:14 localhost kernel: [65052.748365] usb 1-2: new full-speed USB device number 4 using uhci_hcd
Mar 12 20:46:19 localhost kernel: [65057.935395] usb 1-2: New USB device found, idVendor=9ac4, idProduct=4b8f
Mar 12 20:46:19 localhost kernel: [65057.935417] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mar 12 20:46:19 localhost kernel: [65057.935431] usb 1-2: Product: ProxMark-3 RFID Instrument
Mar 12 20:46:19 localhost kernel: [65057.935443] usb 1-2: Manufacturer: J. Westhues
Mar 12 20:46:19 localhost kernel: [65057.935454] usb 1-2: SerialNumber: ChangeMe
Mar 12 20:46:19 localhost kernel: [65057.947730] hid-generic 0003:9AC4:4B8F.0004: hiddev0,hidraw1: USB HID v1.00 Device [J. Westhues ProxMark-3 RFID Instrument] on usb-0000:00:1d.0-2/input0
Mar 12 20:46:19 localhost mtp-probe: checking bus 1, device 4: "/sys/devices/pci0000:00/0000:00:1d.0/usb1/1-2"
Mar 12 20:46:19 localhost mtp-probe: bus: 1, device: 4 was not an MTP device

Offline

#3 2014-03-13 04:22:16

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

well i removed modemmanager and no change hmm

Offline

#4 2014-03-13 16:11:45

vivat
Contributor
Registered: 2010-10-26
Posts: 332

Re: debian and proxmark3

Mar 12 20:46:19 localhost kernel: [65057.947730] hid-generic 0003:9AC4:4B8F.0004: hiddev0,hidraw1: USB HID v1.00 Device [J. Westhues ProxMark-3 RFID Instrument] on usb-0000:00:1d.0-2/input0
As you already said, your proxmark is using old USB HID protocol. If you want to run latest firmware, you need to reflash it with OLD software and NEW(USB CDC) bootrom.elf and fullimage.elf.
To do this, you need to find somewhere old flasher that understands HID protocol(before SVN r672) and latest firmware that you can compile yourself.

Offline

#5 2014-03-13 17:03:51

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

vivat wrote:

Mar 12 20:46:19 localhost kernel: [65057.947730] hid-generic 0003:9AC4:4B8F.0004: hiddev0,hidraw1: USB HID v1.00 Device [J. Westhues ProxMark-3 RFID Instrument] on usb-0000:00:1d.0-2/input0
As you already said, your proxmark is using old USB HID protocol. If you want to run latest firmware, you need to reflash it with OLD software and NEW(USB CDC) bootrom.elf and fullimage.elf.
To do this, you need to find somewhere old flasher that understands HID protocol(before SVN r672) and latest firmware that you can compile yourself.

ok i will give it a try. thank you very much.

Offline

#6 2014-03-15 04:45:28

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

I have made some progress but i have hit another road block i get this error when i try to flash the bootrom

root@eeepc-netbook:/home/user/proxmark3/client# ./flasher -b ../bootrom/obj/bootrom.elf
Loading ELF file '../bootrom/obj/bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b60->0x00000b60) [RWX] @0x298
Attempted to write bootloader but bootloader writes are not enabled
Error while loading ../bootrom/obj/bootrom.elf

im holding the button on the proxmark while i plug it in and when i run the cmd. ideas? thank you.

Offline

#7 2014-03-15 08:50:17

midnitesnake
Contributor
Registered: 2012-05-11
Posts: 151

Re: debian and proxmark3

whats happens if you don't push the button on the proxmark?

Offline

#8 2014-03-15 14:22:40

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

midnitesnake wrote:

whats happens if you don't push the button on the proxmark?


same error

Offline

#9 2014-03-15 14:28:43

vivat
Contributor
Registered: 2010-10-26
Posts: 332

Re: debian and proxmark3

root@eeepc-netbook:/home/user/proxmark3/client# ./flasher -b ../bootrom/obj/bootrom.elf
Loading ELF file '../bootrom/obj/bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b60->0x00000b60) [RWX] @0x298
Attempted to write bootloader but bootloader writes are not enabled
Error while loading ../bootrom/obj/bootrom.elf

Which svn rev. do you use to flash that bootrom?

Offline

#10 2014-03-15 15:10:18

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

vivat wrote:

root@eeepc-netbook:/home/user/proxmark3/client# ./flasher -b ../bootrom/obj/bootrom.elf
Loading ELF file '../bootrom/obj/bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b60->0x00000b60) [RWX] @0x298
Attempted to write bootloader but bootloader writes are not enabled
Error while loading ../bootrom/obj/bootrom.elf

Which svn rev. do you use to flash that bootrom?

665

svn checkout -r 665 http://proxmark3.googlecode.com/svn/trunk/ proxmark3

Offline

#11 2014-03-15 16:01:35

vivat
Contributor
Registered: 2010-10-26
Posts: 332

Re: debian and proxmark3

OK, you should do this:
sudo ./path_to_old_r665/client/flasher -b ../path_to_latest_HEAD_svn_revision/bootrom/obj/bootrom.elf
Push the button and plug pm3 to USB port. If that doesn't help, replug it again.

Offline

#12 2014-03-15 22:36:56

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

vivat wrote:

OK, you should do this:
sudo ./path_to_old_r665/client/flasher -b ../path_to_latest_HEAD_svn_revision/bootrom/obj/bootrom.elf
Push the button and plug pm3 to USB port. If that doesn't help, replug it again.

ok im trying to compile the new firmware and i get the following errors:

root@eeepc-netbook:/home/user/proxmark3-new# make all
make -C bootrom all
make[1]: Entering directory `/home/user/proxmark3-new/bootrom'
../common/cmd.c:34:20: fatal error: string.h: No such file or directory
#include "string.h"
                    ^
compilation terminated.
make[1]: Leaving directory `/home/user/proxmark3-new/bootrom'
make[1]: Entering directory `/home/user/proxmark3-new/bootrom'
perl ../tools/mkversion.pl .. > version.c || cp ../common/default_version.c version.c
arm-none-eabi-gcc -c -I../include -I../common -Wall -Werror -pedantic -std=c99 -I. -Os -mthumb -mthumb-interwork -o obj/version.o version.c
In file included from ../include/usb_cmd.h:21:0,
                 from ../include/proxmark3.h:66,
                 from version.c:1:
/usr/lib/gcc/arm-none-eabi/4.8/include/stdint.h:9:26: fatal error: stdint.h: No such file or directory
# include_next <stdint.h>
                          ^
compilation terminated.
make[1]: *** [obj/version.o] Error 1
make[1]: Leaving directory `/home/user/proxmark3-new/bootrom'
make: *** [bootrom/all] Error 2


ideas?

Offline

#13 2014-03-16 15:02:56

vivat
Contributor
Registered: 2010-10-26
Posts: 332

Re: debian and proxmark3

Something is wrong with your ARM toolchain. Did you follow the instructions?

Offline

#14 2014-03-16 15:26:02

midnitesnake
Contributor
Registered: 2012-05-11
Posts: 151

Re: debian and proxmark3

Have you followed the instructions on the wiki (https://code.google.com/p/proxmark3/wiki/Linux) on installing the ARM toolkit?

Offline

#15 2014-03-16 16:24:08

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

ok i was able to fix the toolchain thank you. i thought i needed gcc-arm-none-eabi but turns out i didnt.

Offline

#16 2014-03-16 16:26:35

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

same error as before hmm

root@eeepc-netbook:/home/user/proxmark3/client# ./flasher -b ../../proxmark3-new/bootrom/obj/bootrom.elf
Loading ELF file '../../proxmark3-new/bootrom/obj/bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b60->0x00000b60) [RWX] @0x298
Attempted to write bootloader but bootloader writes are not enabled
Error while loading ../../proxmark3-new/bootrom/obj/bootrom.elf

do i need a older flasher?

Offline

#17 2014-03-16 18:26:11

midnitesnake
Contributor
Registered: 2012-05-11
Posts: 151

Re: debian and proxmark3

you need the old flasher with the new bootrom
think i used the following last year?
svn checkout -r 623 http://proxmark3.googlecode.com/svn/trunk/ proxmark3-old

Offline

#18 2014-03-16 19:48:33

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

midnitesnake wrote:

you need the old flasher with the new bootrom
think i used the following last year?
svn checkout -r 623 http://proxmark3.googlecode.com/svn/trunk/ proxmark3-old

623 worked but i still have the HID issue here is dmesg:
[101989.456330] usb 2-2: new full-speed USB device number 47 using uhci_hcd
[101994.642993] usb 2-2: New USB device found, idVendor=9ac4, idProduct=4b8f
[101994.643019] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[101994.643037] usb 2-2: Product: ProxMark-3 RFID Instrument
[101994.643053] usb 2-2: Manufacturer: J. Westhues
[101994.643067] usb 2-2: SerialNumber: ChangeMe
[101994.652674] generic-usb 0003:9AC4:4B8F.001B: hiddev0,hidraw1: USB HID v1.00 Device [J. Westhues ProxMark-3 RFID Instrument] on usb-0000:00:1d.0-2/input0

however when i hold the button down and plug it in i get this in dmesg:
[102139.716360] hub 1-0:1.0: unable to enumerate USB device on port 2
[102140.448336] usb 2-2: new full-speed USB device number 48 using uhci_hcd
[102140.623077] usb 2-2: New USB device found, idVendor=2d2d, idProduct=504d
[102140.623096] usb 2-2: New USB device strings: Mfr=1, Product=0, SerialNumber=0
[102140.623110] usb 2-2: Manufacturer: proxmark.org
[102140.625666] cdc_acm 2-2:1.0: This device cannot do calls on its own. It is not a modem.
[102140.625786] cdc_acm 2-2:1.0: ttyACM0: USB ACM device

at this point i can connect using the proxmark bin but commands never return.and after a minute it clicks and i lose connection and this is in dmesg:
Mar 16 13:52:22 eeepc-netbook kernel: [102518.400081] usb 2-2: new full-speed USB device number 53 using uhci_hcd
Mar 16 13:52:28 eeepc-netbook kernel: [102523.583000] usb 2-2: New USB device found, idVendor=9ac4, idProduct=4b8f
Mar 16 13:52:28 eeepc-netbook kernel: [102523.583015] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mar 16 13:52:28 eeepc-netbook kernel: [102523.583027] usb 2-2: Product: ProxMark-3 RFID Instrument
Mar 16 13:52:28 eeepc-netbook kernel: [102523.583036] usb 2-2: Manufacturer: J. Westhues
Mar 16 13:52:28 eeepc-netbook kernel: [102523.583045] usb 2-2: SerialNumber: ChangeMe
Mar 16 13:52:28 eeepc-netbook kernel: [102523.592634] generic-usb 0003:9AC4:4B8F.001D: hiddev0,hidraw1: USB HID v1.00 Device [J. Westhues ProxMark-3 RFID Instrument] on usb-0000:00:1d.0-2/input0
Mar 16 13:52:28 eeepc-netbook mtp-probe: checking bus 2, device 53: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-2"
Mar 16 13:52:28 eeepc-netbook mtp-probe: bus: 2, device: 53 was not an MTP device

Offline

#19 2014-03-16 23:18:18

emada
Contributor
Registered: 2014-03-12
Posts: 13

Re: debian and proxmark3

i got it. needed to also load the other new images with the new flasher after the bootloader

Offline

#20 2014-03-17 06:52:01

vivat
Contributor
Registered: 2010-10-26
Posts: 332

Re: debian and proxmark3

Good to see that you have solved the problem

Offline

Board footer

Powered by FluxBB