Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2013-03-01 12:34:31

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Help compiling windows client

Hi guys, after sending the make command I receive (at the very end) this error compiling under windows 7:
50780153.png

Arm and bootloader files are compiling fine; the client compiling error does not appear using cdc branch... where should I look at to solve that error ?

Last edited by asper (2013-03-02 17:27:27)

Offline

#2 2013-03-01 14:18:11

moebius
Contributor
Registered: 2011-03-10
Posts: 206

Re: Help compiling windows client

There's something missing about your QT lib.

Offline

#3 2013-03-01 14:47:12

rule
Moderator
Registered: 2008-05-21
Posts: 416

Re: Help compiling windows client

Uploaded a new mingw-proxmark.zip. The GUI based on QT should work again!

Offline

#4 2013-03-02 17:17:43

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

All is compiling fine with the new MinGW (tested r664 for both official and cdc branch) ! Thank you ! I only need explanations on how to flash the new bootloader so I can make a guide !

Stand alone windows client may require those libraries (4.5MB).

Last edited by asper (2013-03-02 17:47:22)

Offline

#5 2013-03-02 18:05:06

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

Bootrom updated ! Also flashed OS and FPG... REALLY REALLY FASTER THAN OLD METHOD !!!!!!!! My fingers thank you a lot smile


This is my actual hw version (all flashed files form r664):
scrsx.png

Is it possible to restore the svn version in both OS image and bootrom ?

I am making a update/flashing guide !

Last edited by asper (2013-03-02 18:05:31)

Offline

#6 2013-03-03 08:37:02

rule
Moderator
Registered: 2008-05-21
Posts: 416

Re: Help compiling windows client

Good to hear everything works Asper, thank you very much for testing.

I figured out why the OS/Bootrom version info is not available if you compile in Windows. The info is embedded into the firmware by a PERL script. If you don't have PERL installed, this simple fails to put any info in there.

The solution is simple, just install PERL (For windows). You can download a (32- or 64-bit) binary installation package from here:
http://strawberryperl.com/

I've updated the instructions that comes with the MinGW-proxmark.zip download, so that uses can prepare them self better before compiling on Windows.

If you want, you can make a complete windows binary snapshot package (32-bit and 64-bit version?) with all the executables, libraries, compiled os/fpga/bootrom and other necessary files (including maybe flasher_old.exe). I can put it as download in the Proxmark SVN, so Windows-users could migrate easier. At least, it is not so hard to build from scratch now in Windows, but as you know, Windows-users are much more familiar depended on binary releases wink

Offline

#7 2013-03-03 09:10:40

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

I think you got the problem man ! In fact i receive (since a few builds) 2 perl errors (even if binaries compile fine and are working) in version.c file, here are the 2 errors screenshot:

perl1.png
perl2.png

I already have perl installed but I alsto tryed to install the strawberry perl you linked with the same (bad) results... maybe a script incompatibility with windows ?

If I manage to make all working fine I will release binaries for Win64 then I will try to compile under Win32 and If I am successfull I will release 2 different compiled versions.

If you want I am on IRC now.

Last edited by asper (2013-03-03 09:17:42)

Offline

#8 2013-03-03 10:42:11

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

UPDATE:

The problem seems to be under WIndows7 64 bit (maybe all 64bit WIn versions) because .elf files are compiling fine under Windows XP 32bit.
Client binaries work fine in 32bit and 64bit systems; I mean you can compile them under Win32 and they will work under Win64 and vice versa.

Here is a full r664 Windows release (.elfs+.exes+README+old bootloader flashing guide)

Last edited by asper (2013-03-03 10:50:13)

Offline

#9 2013-03-03 14:07:45

rule
Moderator
Registered: 2008-05-21
Posts: 416

Re: Help compiling windows client

asper wrote:

UPDATE:

The problem seems to be under WIndows7 64 bit (maybe all 64bit WIn versions) because .elf files are compiling fine under Windows XP 32bit.
Client binaries work fine in 32bit and 64bit systems; I mean you can compile them under Win32 and they will work under Win64 and vice versa.

Here is a full r664 Windows release (.elfs+.exes+README+old bootloader
flashing guide)

Could it be possible, that libusb0.dll is missing in the package? (needed for flasher-OLD.exe)

Offline

#10 2013-03-03 15:01:24

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

I used that package to flash so I don't think it's needed to flash with old flasher if your pm3 is correctly recognized by win.

Last edited by asper (2013-03-03 15:49:08)

Offline

#11 2013-03-07 18:22:58

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

r672 compiled for Windows  <-- compiled fine under Windows XP 32bit, works on Win7 64bit.

I still have perl problems under Win7 64bit (it compiles but no version number "injected" in binaries - see previous posts)

Last edited by asper (2013-03-07 18:26:23)

Offline

#12 2013-03-07 21:35:38

rule
Moderator
Registered: 2008-05-21
Posts: 416

Re: Help compiling windows client

I tried, but see no problem in Windows 7 (64-bit). Are you sure you downloaded the 64-bit version of strawberry-perl?

Offline

#13 2013-03-08 09:57:31

C0Y0-Ck3r
Contributor
Registered: 2012-11-08
Posts: 87

Re: Help compiling windows client

Everything is compiled well for me, but the problem I got is that when executing proxmark3 COM3 I got the proxmark3 prompt and when executing hw version nothing happens, it's like that the data is not sent to the proxmark. Any ideas why ?

Offline

#14 2013-03-08 11:36:46

rule
Moderator
Registered: 2008-05-21
Posts: 416

Re: Help compiling windows client

You are sure you have it connected to COM3 (check the device manager).
If you connect to a COM port that belongs to a different device, you will most likely get no any answer at all.

Offline

#15 2013-03-08 12:43:55

C0Y0-Ck3r
Contributor
Registered: 2012-11-08
Posts: 87

Re: Help compiling windows client

No its the good one, and the hw version worked one time, after that It wouldn't work hmm

Offline

#16 2013-03-08 14:15:43

C0Y0-Ck3r
Contributor
Registered: 2012-11-08
Posts: 87

Re: Help compiling windows client

I think its ok, asper suggested to try it on a real and not on a vmware. I'll do that and the next tutorial will cover all the setup of the new firmware...

Offline

#17 2013-03-13 19:34:09

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

Here is r679 FULL compiled for Windows.

Found the problem with perl under Win7 (maybe not only Win7, I think it can happens on other Win versions too) ! Here is my explanation of the problem:

i had a "bad path" for perl executable; the solution was going to path variable settings (look here where to go: http://www.computerhope.com/issues/ch000549.htm#1) and I put the perl folder path variable at the beginning of the path-line insted of at the end (so it's not a true "bad path" problem but probably windows looks for another perl.exe instead of strawberry one).
pathk.png

Now pm3 is compiling fine under Win7 64bit !

Last edited by asper (2013-03-13 23:31:50)

Offline

#18 2013-03-18 20:46:18

asper
Contributor
Registered: 2008-08-24
Posts: 1,409

Re: Help compiling windows client

Offline

Board footer

Powered by FluxBB