Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

Announcement

Time changes and with it the technology
Proxmark3 @ discord

Users of this forum, please be aware that information stored on this site is not private.

#1 2020-12-29 00:38:12

TeamRocket
Contributor
Registered: 2020-12-26
Posts: 8

Cant Flash Proxmark3 Firmware/Bootloader!

Hey guys,

First of all, thanks in advance for any help. Long time reader of the forums, first post.

Having troubles flashing a proxmark. I've done this plenty of times before. It's a proxmark3 easy... usually don't even need to hold the button, but I tried the button press method as well numerous times, but it appears my proxmark is... I guess... stuck, on an iceman repo firmware. It just doesn't want to flash.

The only way I can get the Flash All batch to pick up proxmark is when i let go of the button, then it disconnects, reconnects and tries to find it on same com but it isn't in bootloader so just sits trying to find it. When its at that point it just has a green and orange light.

If I hold the button, it just endlessy searches for proxmark on com8 and times out.

Here's if I just run it holding no buttons:



Loading ELF file '..\firmware_win\bootrom\bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000c7c->0x00000c7c) [R X] @0x298

Loading ELF file '..\firmware_win\fullimage.elf'...
Loading usable ELF segments:
0: V 0x00102000 P 0x00102000 (0x0002f5d0->0x0002f5d0) [R X] @0x94
1: V 0x00200000 P 0x001315d0 (0x0000120c->0x0000120c) [RW ] @0x2f664
Note: Extending previous segment from 0x2f5d0 to 0x307dc bytes

Waiting for Proxmark to appear on com8 .
Found.
Entering bootloader...
(Press and release the button only to abort)
Waiting for Proxmark to appear on com8 ........................................................................................................................
ERROR: invalid serial port
Error: Proxmark not found.
Press any key to continue . . .





Here's the firmware/bootloader/device info:



Prox/RFID mark3 RFID instrument
bootrom: RRG/Iceman/master/release (git)
os: master/v3.1.0-163-g00848e0-suspect 2019-11-25 13:35:14
fpga_lf.bit built for 2s30vq100 on 2019/11/21 at 09:02:37
fpga_hf.bit built for 2s30vq100 on 2019/11/13 at 14:52:19
SmartCard Slot: not available

uC: AT91SAM7S256 Rev C
Embedded Processor: ARM7TDMI
Nonvolatile Program Memory Size: 256K bytes. Used: 207449 bytes (79%). Free: 54695 bytes (21%).
Second Nonvolatile Program Memory Size: None
Internal SRAM Size: 64K bytes
Architecture Identifier: AT91SAM7Sxx Series
Nonvolatile Program Memory Type: Embedded Flash Memory

Offline

#2 2020-12-29 06:51:47

TeamRocket
Contributor
Registered: 2020-12-26
Posts: 8

Re: Cant Flash Proxmark3 Firmware/Bootloader!

Solved it, installed the drivers in compiled latest main git repo and then realized its jumping com ports, connected in normal mode set com port to com10 connected while holding button, set com to com10, re-ran and success.

Last edited by TeamRocket (2020-12-29 06:52:14)

Offline

#3 2020-12-29 06:56:25

iceman
Administrator
Registered: 2013-04-25
Posts: 7,139
Website

Re: Cant Flash Proxmark3 Firmware/Bootloader!

your bootloader might change usb enumeration,  if you are on a different or older one.
Try the button-trick https://github.com/RfidResearchGroup/pr … n-os-image


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

Board footer

Powered by FluxBB