Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-12-26 20:54:03

Registered: 2019-10-14
Posts: 6

[SOLVED] [RDV2] De-bricking proxmark3 using raspberry

Good afternoon,

I have followed this wiki  but for the compilation of the proxmark git (instead the two .elf files are stored inside my raspberry)

When I start the connection between the proxmark and the raspberry someth. fails:

Info : Listening on port 6666 for tcl connections
Info : Listening on port 4444 for telnet connections
Info : BCM2835 GPIO JTAG/SWD bitbang driver
Info : JTAG and SWD modes enabled
Info : clock speed 1001 kHz
Error: JTAG scan chain interrogation failed: all zeroes
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: sam7x.cpu: IR capture error; saw 0x00 not 0x01
Warn : Bypassing JTAG setup events due to errors
Info : Embedded ICE version 0
Error: unknown EmbeddedICE version (comms ctrl: 0x00000000)
Info : sam7x.cpu: hardware has 2 breakpoint/watchpoint units
Info : Listening on port 3333 for gdb connections

Why does the JTAG interrogation fail ?
It seems to me that everything is correctly configured

When i try to halt the Proxmark it times out. This makes perfect sense as the connection doesn't seems to be correctly stablished.

telnet localhost 4444
Trying ::1...
Connected to localhost.
Escape character is '^]'.
Open On-Chip Debugger
> halt
Halt timed out, wake up GDB.
timed out while waiting for target halted

Last edited by rogerjerry (2019-12-27 20:46:08)


#2 2019-12-27 20:45:50

Registered: 2019-10-14
Posts: 6

Re: [SOLVED] [RDV2] De-bricking proxmark3 using raspberry

Solved the issue by reinstalling everything on a fresh raspberry install


Board footer

Powered by FluxBB