Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2019-09-06 02:31:19

Registered: 2018-04-09
Posts: 6

[SOLVED] Communicating with Proxmark3 device failed

Okay, so I bought a Proxmark3 Rdv4 from Hackerware House (

I'm running Ubuntu Linux 19.04 and I followed the Linux instructions found here:

In attempting to flash the bootrom and image I followed the instructions found here:

When I get to the part where I call the command
proxmark3-flasher /dev/ttyACM0 -b /usr/local/share/proxmark3/firmware/bootrom.elf /usr/local/share/proxmark3/firmware/fullimage.elf

I get a few errors. Namely:

!!] Note: Your bootloader does not understand the new CMD_BL_VERSION command           
[!!] It is recommended that you first update your bootloader alone,

!!] Note: Your bootloader does not understand the new CHIP_INFO command           
[!!] It is recommended that you first update your bootloader alone, 

It then says "Aborted on Error" and stops.

It suggested updating the bootloader alone, so I tried calling pm3-flash-bootrom instead.  This repeated these errors but seemed to be able to complete anyways. It just ends with  "... OK. All done".

When I try to run any of the pm3-flash functions again I get the same error
"[!] Communicating with Proxmark3 device failed  "

The first time this happened I waited 10 minutes and then canceled the execution and unplugged my proxmark. Googling this error brought me to a previous post with a similar position

In it, iceman suggested

"try one hand button trick.
unplug device,   press and hold button (don't let go),  flash fullimage,  first when flashing finished and you get OK,  you can release button."

But when I do this, I get the same error "Communicating with Proxmark3 device failed"

Also, I tried several times to run the various pm3-flash programs while holding down the button. When I do this I also get the error: Received packet OLD frame with payload too short?

Does anyone have any suggestions?

EDIT: Looking back over the instructions, I think I just completely missed the line about Modem Manager. I just missed it by mistake. This may be the problem.

EDIT2: Yep, that was it! I followed the instructions on the wiki for how to fix it and it seems to be working now.

Last edited by Kurushimi (2019-09-06 04:33:50)


#2 2019-09-06 16:17:15

Registered: 2013-04-25
Posts: 6,654

Re: [SOLVED] Communicating with Proxmark3 device failed

Yup, you should follow the instructions in the message,   flash bootrom, and then afterwards flash fullimage.
Regardless how, you managed it and now can enjoy your RDV4 to the fullest!

If you feel the love,



Board footer

Powered by FluxBB