Proxmark3 community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

You are not logged in.


Time changes and with it the technology
Proxmark3 @ discord

Users of this forum, please be aware that information stored on this site is not private.

#1 2019-07-16 17:13:48

Registered: 2019-07-04
Posts: 5

[solved] [RDV4] usart: "This command is not available in this mode"

Trying to change the bluetooth PIN on my freshly mounted "blue shark" as described in the uart_notes, the "usart" command seems not accessible:

[ PROXMARK RDV4 Extras ]          
  FPC USART for BT add-on support: present           
 [ ARM ]
  bootrom: RRG/Iceman/master/d3b6a8e1 2019-07-16 19:36:00
       os: RRG/Iceman/master/d3b6a8e1 2019-07-16 19:36:09
  compiled with GCC 7.3.1 20180622 (release) [ARM/embedded-7-branch revision 261907]

Neither is "usart" listed in the global help menu, nor is it callable:

[usb] pm3 --> usart
[!] This command is not available in this mode

cmdparser.c has a function IfPm3FpcUsartDevFromUsb() which seems to be used to determine whether to have a "usart" command at all, which in turn seems to consult pm3_capabilities.compiled_with_fpc_usart_dev - and this is the point where I wonder if I am the first one to attempt this...

So, before I start digging in how the capabilities are determined: Is this supposed to work at all, and does it work with other devices? Does this actually verify something in the hardware, or is it just depending on the (seemingly several) compile time options that can be set?

As long as an alternative explanation might be a hardware fault (I have not yet seen the thing on my mobile phone in its bluetooth device list...), I don't quite know where to debug this further... (However, the "charge" light is red, the device runs on battery power, and when I switch on BT, the blue LED blinks, so it is somehow connected and alive.)

Last edited by wanderer (2019-07-17 10:43:11)


#2 2019-07-16 18:07:13

Registered: 2013-04-25
Posts: 9,519

Re: [solved] [RDV4] usart: "This command is not available in this mode"

Not really,   but you do need to compile the firmware with the correct flag inside  Makefile.platform file. 


As mentioned in the document you linked to.

This USART can be reached from the host client (if connected via USB-CDC) through the following commands, available in FPC_USART_DEV build:


#3 2019-07-17 10:41:42

Registered: 2019-07-04
Posts: 5

Re: [solved] [RDV4] usart: "This command is not available in this mode"

Yup, this helped.

On my first attempt I have only compiled the client with that additional option, but did not update the firmware, that was not enough.

Thank you! Let's see if I can find out how to add a "solved" tag to this thread...


Board footer

Powered by FluxBB