Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.

"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2018-05-13 15:12:41

Registered: 2017-09-20
Posts: 20

Proxmark stuck Upgrading firmware

Hello all,

A small new problem came to my attention when I tried to upgrade the firware.
I am under linux and I used :

./flasher /dev/ttyACM0 ../armsrc/obj/fullimage.elf
Loading ELF file '../armsrc/obj/fullimage.elf'...
Loading usable ELF segments:
0: V 0x00102000 P 0x00102000 (0x0002ccd8->0x0002ccd8) [R X] @0x94
1: V 0x00200000 P 0x0012ecd8 (0x00001930->0x00001930) [RW ] @0x2cd6c
Note: Extending previous segment from 0x2ccd8 to 0x2e608 bytes

Waiting for Proxmark to appear on /dev/ttyACM0. Found.
Entering bootloader...
(Press and release the button only to abort)
Waiting for Proxmark to reappear on /dev/ttyACM0....... Found.

Writing segments for file: ../armsrc/obj/fullimage.elf
 0x00102000..0x00130607 [0x2e608 / 372 blocks].....................................................

After that the proxmark kept stuck, nothing is happening anymore and my leds A and C are lit (not flashing just lit)
And by looking in the usb I see the proxmark but when I go to the port it say invalid port.
So basically cannot access my proxmakr anymore

Is there anything I can do ?

Thank you in advance

Last edited by T. (2018-05-13 15:13:29)


#2 2018-05-16 20:45:55

Registered: 2018-05-16
Posts: 17

Re: Proxmark stuck Upgrading firmware

Hi T.

Iam facing the exact same issue. Stuck at the flashing step just like you.

I just tried to run the flash again, and Iam now stock in  the previous step "Waiting for Proxmark to appear on /dev/ttyACM0. Found." just before entering the bootloader.

I followed all the github step and unfortunately, it didnt sucess...


#3 2018-05-17 00:53:19

Registered: 2018-05-16
Posts: 17

Re: Proxmark stuck Upgrading firmware

I just tried again but this time under windows 7. I was able to flash the device without pb. it is working now.


#4 2018-05-17 07:37:50

Registered: 2013-06-04
Posts: 704

Re: Proxmark stuck Upgrading firmware

Depending on the age of the previous firmware it may be necessary to flash the bootrom as well.


Board footer

Powered by FluxBB