Proxmark developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2014-02-26 02:52:50

dedosoa
Contributor
Registered: 2014-02-26
Posts: 12

Stuck, flashing errors

I am very sorry, i have tried all things in forum and do a lot of google search. No way i am stuck.
I recently bought a proxmark3. After getting uo to date and reading all documentation on web, finally i am at this point.
I never knew wich hw version the proxmark came with. the fact is now i can do hw version with no errors so it seems like it is not bricked. Here the results using r648

sansa@marcotius:~/proxold/client$ sudo ./proxmark3 

Connected units:
	1. SN: ChangeMe [002/093]
proxmark3> hw version
#db# Prox/RFID mark3 RFID instrument                 
#db# bootrom: svn 648 2014-02-11 12:26:08                 
#db# os: svn 651 2013-01-31 14:52:31                 
#db# FPGA image built on 2012/ 1/ 6 at 15:27:56

AT this point whatever i do it gives ACK errors. No succes on upgrading new bootrom with old flasher neither using r648 or 651 or 623 this last one is supposed to be the old flasher. I think the problem is with the issue involving holding the button and connecting directly to bootrom it gives me this error:

 sansa@marcotius:~/prox623/client$ sudo ./flasher -b ~/pm3/bootrom/obj/bootrom.elf 
Loading ELF file '/home/sansa/pm3/bootrom/obj/bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b60->0x00000b60) [RWX] @0x298

Waiting for Proxmark to appear on USB....
Connected units:
	1. SN: ChangeMe [002/112]
 Found.
ReceiveCommandPoll returned 0
Error: Unknown Proxmark mode

then it reboots (i think so) the red ans yellow light get solid even with the button released  and this happens:

sansa@marcotius:~/prox623/client$ sudo ./flasher -b ~/pm3/bootrom/obj/bootrom.elf 
Loading ELF file '/home/sansa/pm3/bootrom/obj/bootrom.elf'...
Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b60->0x00000b60) [RWX] @0x298

Waiting for Proxmark to appear on USB...
Connected units:
	1. SN:  [002/112]
...
Connected units:
	1. SN: ChangeMe [002/113]
 Found.
Entering bootloader...
(Press and release the button only to abort)
Waiting for Proxmark to reappear on USB....
Connected units:
	1. SN: ChangeMe [002/114]
 Found.
ReceiveCommandPoll returned 0
Note: Your bootloader does not understand the new START_FLASH command
      It is recommended that you update your bootloader


Flashing...
Writing segments for file: /home/sansa/pm3/bootrom/obj/bootrom.elf
 0x00100000..0x001001ff [0x200 / 2 blocks]write failed: could not set config 1: Protocol error!
Trying to reopen device...

Connected units:
	1. SN:  [002/114]

keeps on this point...

Can someone help me in a newbie way cause i don know what i can do. May be someone can advise me what is happening or if i had to try an older revision?

Thanks in advance.


P.S. I am using debian wheezy. Similar issues with a ubuntu 12.04 and usb 3.0 getting me mad.

Offline

#2 2014-02-26 04:28:22

vivat
Contributor
Registered: 2010-10-26
Posts: 332

Re: Stuck, flashing errors

Do you have a JTAG?

Offline

#3 2014-02-26 06:00:39

Enio
Contributor
Registered: 2013-09-24
Posts: 175

Re: Stuck, flashing errors

In this thread are some useful info, have you studied it yet? (http://www.proxmark.org/forum/viewtopic.php?id=1668)
Can you be sure nothing is interfering the connection? (i.e. that modem-manager mentioned there)
You always executed make clean between recompiles? Not that you have a bad flasher version from an earlier compilation..

You can always revive it with a JTAG Connector but youll have to spend a few bucks on it or build one yourself.

Last edited by Enio (2014-02-26 06:03:05)


Proxmark IRC channel can easily be joined off this official webchat applet: [url] http://webchat.freenode.net/?channels=#proxmark3[/url]
You can start a private chat with /msg <nickname> <text>

Offline

#4 2014-02-26 22:58:52

dedosoa
Contributor
Registered: 2014-02-26
Posts: 12

Re: Stuck, flashing errors

Thanks for the answers.
I didn't want to go to jtag issue. Anyway i did everything that i found on the web. without succes.
I will update on findings if it can help another one.

Offline

#5 2014-03-08 21:40:42

dedosoa
Contributor
Registered: 2014-02-26
Posts: 12

Re: Stuck, flashing errors

Hi all.
Good news. Finally i've got my proxmark3 running. well, at least making what it is suposed to do and me learning interesting things.

What i've done, for helping others with same problems, i had to use jtag for pulling the last images on it.
How i did it. Well do a lot of google search, break my brain and buy a buspirate (carefull with cable i had to throw mine through the window) then manage to update the image with tutorial and a lot of reading/learning.

Thank for the advices. I Appreciated them a lot. See you in the cards section!!

Offline

#6 2017-07-14 23:10:08

Navster
Contributor
Registered: 2017-07-09
Posts: 43

Re: Stuck, flashing errors

I'm having the same issue as you were. Just got a bus pirate and having a hard time wrapping my head around it. Any suggestions ? Appreaciate all the help I can get.

Offline

Board footer

Powered by FluxBB