Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2015-11-11 23:08:19

Hawkins
Member
Registered: 2015-09-10
Posts: 9

ERROR: invalid serial port or how to make it work

Hello, everyone!

I have just received my new proxmark3. I am trying to setup it, but no success. Actually I was trying to find the answer on the forum, but can't do that.

I am doing everything in VMWare with Ubuntu 14.04
I used this link to make it work: https://github.com/Proxmark/proxmark3/wiki/Ubuntu-Linux [1]

1) sudo apt-get install p7zip git build-essential libreadline5 libreadline-dev libusb-0.1-4 libusb-dev libqt4-dev perl pkg-config wget
2) Plugged in the device (didn't press the button) and type dmesg. Here is a part of the output:
[ 4224.154068] usb 2-2.2: new full-speed USB device number 11 using uhci_hcd
[ 4224.327036] usb 2-2.2: New USB device found, idVendor=2d2d, idProduct=504d
[ 4224.327040] usb 2-2.2: New USB device strings: Mfr=1, Product=0, SerialNumber=0
[ 4224.327041] usb 2-2.2: Manufacturer: proxmark.org
[ 4224.589320] cdc_acm 2-2.2:1.0: ttyACM0: USB ACM device

According to [1], my device is in CDC mode or whatever it is called

3) I got  devkitARM release 41 and did all the manipulations mentioned there

4) git clone https://github.com/Proxmark/proxmark3.git  and "make" in the created folder

5) if I try to run ./client/proxmark3 /dev/ttyACM0  - I get the following:  ERROR: invalid serial port
Then if I try: hw version  - I get : Sending bytes to proxmark failed - offline (see the picture)
1447279383_screen_shot_2015-11-11_at_22.16.55.jpg

The device doesn't show any life signs (no lights)
What am I doing wrong?

Thanks in advance!

Offline

#2 2015-11-12 18:09:14

Piorun
Contributor
Registered: 2015-01-29
Posts: 57

Re: ERROR: invalid serial port or how to make it work

Could you send the output for command:
ls -al /dev/ttyA*

Offline

#3 2015-11-12 19:25:51

Hawkins
Member
Registered: 2015-09-10
Posts: 9

Re: ERROR: invalid serial port or how to make it work

Hi!
Thanks for the answer.
I tried the command and got:
ls: cannot access /dev/ttyA*: No such file or directory

Offline

#4 2015-11-12 19:39:32

Hawkins
Member
Registered: 2015-09-10
Posts: 9

Re: ERROR: invalid serial port or how to make it work

I can also show you the syslog messages:
arty@ubuntu:~$ tail /var/log/syslog
Nov 12 18:51:26 ubuntu kernel: [15419.632355] usb 2-2.2: new full-speed USB device number 46 using uhci_hcd
Nov 12 18:51:32 ubuntu kernel: [15426.052854] usb 2-2.2: New USB device found, idVendor=9ac4, idProduct=4b8f
Nov 12 18:51:32 ubuntu kernel: [15426.052858] usb 2-2.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Nov 12 18:51:32 ubuntu kernel: [15426.052861] usb 2-2.2: Product: ProxMark-3 RFID Instrument
Nov 12 18:51:32 ubuntu kernel: [15426.052863] usb 2-2.2: SerialNumber: ChangeMe
Nov 12 18:51:32 ubuntu kernel: [15426.077919] hid-generic 0003:9AC4:4B8F.001E: hiddev0,hidraw1: USB HID v1.00 Device [ProxMark-3 RFID Instrument] on usb-0000:02:00.0-2.2/input0
Nov 12 18:51:32 ubuntu mtp-probe: checking bus 2, device 46: "/sys/devices/pci0000:00/0000:00:11.0/0000:02:00.0/usb2/2-2/2-2.2"
Nov 12 18:51:32 ubuntu mtp-probe: bus: 2, device: 46 was not an MTP device
Nov 12 18:52:15 ubuntu dbus[467]: [system] Activating service name='org.freedesktop.ModemManager1' (using servicehelper)
Nov 12 18:52:15 ubuntu dbus[467]: [system] Activated service 'org.freedesktop.ModemManager1' failed: Cannot launch daemon, file not found or permissions invalid

Offline

#5 2015-11-12 20:36:02

Piorun
Contributor
Registered: 2015-01-29
Posts: 57

Re: ERROR: invalid serial port or how to make it work

PM3 device is not mounted as a serial USB so proxmark3 will not work.
You can try to run PM3 client directly on the host (If you use Windows as a main desktop OS )

Offline

#6 2015-11-12 21:09:03

Hawkins
Member
Registered: 2015-09-10
Posts: 9

Re: ERROR: invalid serial port or how to make it work

Thanks, Piorun
I have MacOS and I will try to run it there

Offline

#7 2015-11-13 12:48:59

meter
Contributor
Registered: 2015-07-13
Posts: 77

Re: ERROR: invalid serial port or how to make it work

Hawkins wrote:

I am doing everything in VMWare with Ubuntu 14.04
I used this link to make it work: https://github.com/Proxmark/proxmark3/wiki/Ubuntu-Linux [1]

You should be to read better the wiki.

https://github.com/Proxmark/proxmark3/wiki/Ubuntu-Linux#HID_device

here there is your same problem where I posted a solution, about two weeks ago, the same written on wiki.

Offline

Board footer

Powered by FluxBB