Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2014-04-03 18:37:28

daemon
Contributor
Registered: 2014-04-03
Posts: 11

Trying to compile to upgrade fw, strange error

Hi guys,

I'm hoping someone can help me out. I have Ubuntu 13.10 installed in a VM on a MacBook. I have successfully detected the Proxmark3 as using USB, but it shows the old HID interface so I want to try to update the FW to communicate with a new version.

Anyhow, I checked out the latest version (and an old one previously to update the FW) and try a "make clean && make all". Most of it goes well with the occasional warning but then I get an error:

gcc -std=c99 -I. -I../include -I../common -I/opt/local/include -Wall -Wno-unused-function  -g -O4 -DHAVE_GUI -c -o obj/flash.o flash.c
In file included from flash.c:19:0:
proxendian.h:22:4: error: #error Define BYTE_ORDER to be equal to either LITTLE_ENDIAN or BIG_ENDIAN
#  error Define BYTE_ORDER to be equal to either LITTLE_ENDIAN or BIG_ENDIAN
    ^
make[1]: *** [obj/flash.o] Error 1
make[1]: Leaving directory `/home/dm/pm3/client'
make: *** [client/all] Error 2

It seems like a strange error to have so I'm wondering if something didn't go right. Has anyone else had issues like this before?

Offline

#2 2014-04-04 14:06:27

holiman
Contributor
Registered: 2013-05-03
Posts: 566

Re: Trying to compile to upgrade fw, strange error

Proxendian.h:

#ifdef _WIN32
# define HOST_LITTLE_ENDIAN
#else
# include <sys/types.h>
# ifndef BYTE_ORDER
#  define BYTE_ORDER __BYTE_ORDER
#  define LITTLE_ENDIAN __LITTLE_ENDIAN
#  define BIG_ENDIAN __BIG_ENDIAN
# endif
# if !defined(BYTE_ORDER) || (BYTE_ORDER != LITTLE_ENDIAN && BYTE_ORDER != BIG_ENDIAN)
#  error Define BYTE_ORDER to be equal to either LITTLE_ENDIAN or BIG_ENDIAN
# endif
# if BYTE_ORDER == LITTLE_ENDIAN
#  define HOST_LITTLE_ENDIAN
# endif
#endif

I don't know why it's not defined. If you're on ubuntu, _WIN32 shouldn't be set, and the preceding lines before the error defines the BYTE_ORDER. Strange.

Offline

#3 2014-04-05 07:52:10

daemon
Contributor
Registered: 2014-04-03
Posts: 11

Re: Trying to compile to upgrade fw, strange error

Hmmmm yeah that is weird. Thanks for the info. I will have to check Proxendian.h to see if I can spot anything wrong with the file itself. I was able to update the bootrom/fgpa/OS in a Windows VM in the meantime so I can get going trying some things out. Ubuntu seems to work well for the client though. I'll update if I find anything!

Offline

#4 2014-12-15 19:59:19

68030
Member
Registered: 2014-12-15
Posts: 4

Re: Trying to compile to upgrade fw, strange error

Hey Daemon, any update on this issue?  I'm running into the same error on Ubuntu 14.04.  I've had a myriad of other errors, but this is the most recent.

Offline

Board footer

Powered by FluxBB