Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2016-06-27 03:38:33

jayw0k
Contributor
Registered: 2016-06-27
Posts: 3

PM3 Firmware Flashing

I have followed the wiki, 'getting started' on the google code site, and various forum posts on this topic, but still cannot seem to resolve whatever issue I am having.  The client software does function correctly & can also capture/replay cards in standalone mode.  Details:

OS: Ubuntu 16.04 LTS VM on OSX host
all steps run as root
cloned the github repo
installed devkitArm per instructions
purged modemmanager
added blacklist file
added gcc-arm-none-eabi
/opt/proxmark3/make clean
/opt/proxmark3/make
/opt/proxmark3/client/hid-flasher/make
./flasher -b ../../bootrom/obj/bootrom.elf  (from /opt/proxmark3/client/hid-flasher/)
result is: "Waiting for Proxmark to appear on USB..............."
same result when holding pm3 button while connecting

dmesg output:

[17094.026514] usb 2-2.2: new full-speed USB device number 30 using uhci_hcd
[17094.196508] usb 2-2.2: New USB device found, idVendor=2d2d, idProduct=504d
[17094.196513] usb 2-2.2: New USB device strings: Mfr=1, Product=0, SerialNumber=0
[17094.196515] usb 2-2.2: Manufacturer: proxmark.org
[17094.215419] cdc_acm 2-2.2:1.0: ttyACM0: USB ACM device

hw ver output:

proxmark3> hw ver
Prox/RFID mark3 RFID instrument          
bootrom: master/v2.2 2015-07-31 11:28:11
os: master/v2.2 2015-07-31 11:28:12
LF FPGA image built for 2s30vq100 on 2015/03/06 at 07:38:04
HF FPGA image built for 2s30vq100 on 2015/06/22 at 21:47:54
          
uC: AT91SAM7S512 Rev B          
Embedded Processor: ARM7TDMI          
Nonvolatile Program Memory Size: 512K bytes. Used: 162219 bytes (31%). Free: 362069 bytes (69%).          
Second Nonvolatile Program Memory Size: None          
Internal SRAM Size: 64K bytes          
Architecture Identifier: AT91SAM7Sxx Series          
Nonvolatile Program Memory Type: Embedded Flash Memory

I did see two different errors when compiling:

fpga_compress.c: In function ‘zlib_compress’:
fpga_compress.c:90:20: warning: format ‘%lu’ expects argument of type ‘long unsigned int’, but argument 3 has type ‘int’ [-Wformat=]
    fprintf(stderr, "Input files too big (total > %lu bytes). These are probably not PM3 FPGA config files.\n"
                    ^
fpga_compress.c:142:18: warning: format ‘%lu’ expects argument of type ‘long unsigned int’, but argument 3 has type ‘uint32_t {aka unsigned int}’ [-Wformat=]
  fprintf(stderr, "compressed %lu input bytes to %lu output bytes\n", i, compressed_fpga_stream.total_out);
proxusb.c: In function ‘findProxmark’:
proxusb.c:161:9: warning: ignoring return value of ‘fscanf’, declared with attribute warn_unused_result [-Wunused-result]
         fscanf(stdin, "%d", &iSelection);

I have tried removal & installation numerous times, as well as all of the relative suggestions within the previous flashing error related forum posts.  I'm obviously overlooking something.  Any and all help would be greatly appreciated.

Thanks in advance!

Offline

#2 2016-06-27 07:24:24

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: PM3 Firmware Flashing

Looking at your installed bootrom versio,  tells me you don't need the old hid-flasher.  Use the new flasher instead.


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2016-06-27 12:05:10

jayw0k
Contributor
Registered: 2016-06-27
Posts: 3

Re: PM3 Firmware Flashing

I had tried that one as well, and get the "writes not enabled".  Holding the PM3 button does not affect the results.

Loading usable ELF segments:
0: V 0x00100000 P 0x00100000 (0x00000200->0x00000200) [R X] @0x94
1: V 0x00200000 P 0x00100200 (0x00000b38->0x00000b38) [RWX] @0x298
Attempted to write bootloader but bootloader writes are not enabled

I was however able to successfully flash fullimage.elf.

Last edited by jayw0k (2016-06-27 12:16:15)

Offline

#4 2016-06-27 12:21:34

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: PM3 Firmware Flashing

that seems more serious.  Since your bootrom is modern its not an issue at the moment but could be for the future.

Do you have a buspirate/segger ?  With it you should be able to enable writes to your bootrom memory.


http://www.proxmark.org/files/Flash/200 … -howto.pdf
http://shawinnes.com/unbricking-a-proxm … with-jtag/


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

Board footer

Powered by FluxBB