Proxmark3 developers community

Research, development and trades concerning the powerful Proxmark3 device.

Remember; sharing is caring. Bring something back to the community.


"Learn the tools of the trade the hard way." +Fravia

You are not logged in.

#1 2014-12-17 18:49:51

Omikron
Contributor
Registered: 2010-02-12
Posts: 78

Proxmark Client Hanging CONSTANTLY

Hey Guys!

Does anyone know why the PM3 client would hang constantly during use?  I am running the latest git version throughout the last 10 revisions or so and it's either stayed the same or gotten worse, but it's INCREDIBLY frustrating.

Often times commands issued will be delayed for many many seconds (even simple ones like hw version) and will just fail completely other times.  The only time that appears to be "reliable" for command execution is right after starting the client.  It works very consistently, but then deteriorates to a crap-pile just a few commands later.  Exiting (or CTRL-C'ing) out of the client and restarting it resolves the issue every time, even though the PM3 does not have to be power cycled.  This tells me that it's an issue with the client.

Any thoughts?  Has anyone else observed similar frustrations?

Offline

#2 2014-12-17 19:11:22

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: Proxmark Client Hanging CONSTANTLY

Been running latest revision for several months, and I don't experience the same.   Since there has been changes in the fpga-code don't forget to flash the bootrom, and fullimage ...


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#3 2014-12-17 23:15:28

Omikron
Contributor
Registered: 2010-02-12
Posts: 78

Re: Proxmark Client Hanging CONSTANTLY

iceman wrote:

Been running latest revision for several months, and I don't experience the same.   Since there has been changes in the fpga-code don't forget to flash the bootrom, and fullimage ...

Yep, fully aware of all that, and I always update both when in doubt. :-)

What OS are you on?

If it's relevant, I'm compiling on OS X 10.10.1.

Offline

#4 2014-12-17 23:22:19

iceman
Administrator
Registered: 2013-04-25
Posts: 5,845
Website

Re: Proxmark Client Hanging CONSTANTLY

ubuntu.
I think I saw someting on the forum about osx and problems...


If you feel the love,  https://www.patreon.com/iceman1001

modhex(hkhehghthbhudcfcdchkigiehgduiehg)

Offline

#5 2014-12-18 09:07:55

holiman
Contributor
Registered: 2013-05-03
Posts: 566

Re: Proxmark Client Hanging CONSTANTLY

I don't have those kind of problems; however, sometimes when I do flash, client, flash, client etc (the dev-cycle), I get a USB-crash on the host. It basically kills the entire USB-stack, so even my USB mouse stops working. My laptop is using usb3, xhci. On older ubuntu, sometimes the computer would completely unrecoverably freeze when using usb3 on linux, so I'd always use usb2 (ehci) instead. The xhci is a bit unstable. Even though my problem seems totally unrelated to yours, you could try using only usb2 if possible.

Edited: wrote "usb3 (ehci)", but meant "usb2(ehci)".

Last edited by holiman (2014-12-19 09:01:07)

Offline

#6 2014-12-18 23:29:01

Omikron
Contributor
Registered: 2010-02-12
Posts: 78

Re: Proxmark Client Hanging CONSTANTLY

holiman wrote:

I don't have those kind of problems; however, sometimes when I do flash, client, flash, client etc (the dev-cycle), I get a USB-crash on the host. It basically kills the entire USB-stack, so even my USB mouse stops working. My laptop is using usb3, xhci. On older ubuntu, sometimes the computer would completely unrecoverably freeze when using usb3 on linux, so I'd always use usb3 (ehci) instead. The xhci is a bit unstable. Even though my problem seems totally unrelated to yours, you could try using only usb2 if possible.

Very interesting note about forcing USB2 drivers.  I'll see if there is anyway to do that on OS X.

Offline

Board footer

Powered by FluxBB